Discontinued Support for Android 4 KitKat

To continue using your minutes and take full advantage of Libon, you have to update your app before September 1st, 2019. After this date, you will no longer be able to make calls with your remaining Libon minutes.

 

First, find the Android version installed on your device: go to Settings > About > Software info

Screenshot_2017-11-06-11-24-18.png

 

The Android version on your device is 5.x or superior

You can update your Libon app directly from the Play Store on your Phone:

  • From your Android, open the Play Store : click here
  • Tap on the UPDATE button

 Screenshot_2017-11-06-11-25-22.png

The Android version on your device is lower than 5.x

The Libon app requires the Android OS version 5.x (Lollipop) or superior. So you need to update the Android software on your device:

  • Plug your Android into power 
  • Tap Settings> About > Software Update
  • Tap Download and Install.

Screenshot_2017-11-06-11-24-25.png

Find out more here: Android Help Center

If you are using an older device and you aren't able to update your Android software, you can use your Libon account on another phone.

Why this change?

Android 4 was initially released in 2013. In the time since the release, there have been some major improvements to the Android operating systems. By removing support for Android 4, we are able to streamline our development process and focus resources on supporting newer operating systems and technologies.
A vast majority of Android users have migrated to Android 5 and above. As players migrate from older operating system versions to newer ones, we periodically update our supported device requirements to focus on the devices our playerbase use.
Have more questions? Submit a request
Powered by Zendesk